dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-ruby / git / git-1.7.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 USE_RUBY="ruby24 ruby25 ruby26 ruby27"
6
7 RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
8
9 RUBY_FAKEGEM_GEMSPEC="git.gemspec"
10
11 inherit ruby-fakegem
12
13 DESCRIPTION="Library for using Git in Ruby"
14 HOMEPAGE="https://github.com/schacon/ruby-git"
15 SRC_URI="https://github.com/schacon/ruby-git/archive/v${PV}.tar.gz -> ${P}.tar.gz"
16 RUBY_S="ruby-git-${PV}"
17
18 LICENSE="MIT"
19 SLOT="0"
20 KEYWORDS="~amd64"
21 IUSE="test"
22
23 DEPEND+="test? ( >=dev-vcs/git-1.6.0.0 app-arch/tar )"
24 RDEPEND+=">=dev-vcs/git-1.6.0.0"
25
26 ruby_add_rdepend ">=dev-ruby/rchardet-1.8:1"
27
28 ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/test-unit:2 )"
29
30 all_ruby_prepare() {
31         # Don't use hardcoded /tmp directory.
32         sed -i -e "s:/tmp:${TMPDIR}:" tests/units/test_archive.rb tests/test_helper.rb || die
33 }