dev-python/numpydoc: arm64 keyworded (bug #721130)
[gentoo.git] / dev-ruby / flog / flog-4.6.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 USE_RUBY="ruby23 ruby24 ruby25 ruby26"
6
7 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
8 RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
9
10 inherit ruby-fakegem
11
12 DESCRIPTION="Flog reports the most tortured code in an easy to read pain report"
13 HOMEPAGE="http://ruby.sadi.st/"
14 LICENSE="MIT"
15
16 KEYWORDS="~amd64 ~x86"
17 SLOT="0"
18 IUSE=""
19
20 ruby_add_bdepend "test? ( dev-ruby/minitest )"
21
22 ruby_add_rdepend "
23         dev-ruby/path_expander:1
24         >dev-ruby/ruby_parser-3.1.0:3
25         >=dev-ruby/sexp_processor-4.8:4"
26
27 each_ruby_test() {
28         ${RUBY} -Ilib test/test_flog.rb || die
29 }