dev-ruby/ruby-net-ldap: add 0.14.0
[gentoo.git] / dev-ruby / fakefs / fakefs-0.6.5.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 USE_RUBY="ruby19 ruby20 ruby21 ruby22"
8
9 RUBY_FAKEGEM_RECIPE_TEST="none"
10
11 # requires sdoc
12 RUBY_FAKEGEM_TASK_DOC=""
13
14 RUBY_FAKEGEM_EXTRADOC="CONTRIBUTORS README.markdown"
15
16 inherit ruby-fakegem eutils
17
18 DESCRIPTION="A fake filesystem. Use it in your tests"
19 HOMEPAGE="https://github.com/defunkt/fakefs"
20
21 LICENSE="MIT"
22 SLOT="0"
23 KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
24 IUSE=""
25
26 ruby_add_bdepend "
27         test? (
28                 >=dev-ruby/rspec-3.1:3
29                 >=dev-ruby/test-unit-2.5.1-r1
30         )"
31
32 all_ruby_prepare() {
33         # Remove bundler
34         rm Gemfile || die
35 }
36
37 each_ruby_test() {
38         RSPEC_VERSION=3 ruby-ng_rspec
39         ruby-ng_testrb-2 -Ilib:test test/**/*_test.rb
40 }