dev-python/numpydoc: arm64 keyworded (bug #721130)
[gentoo.git] / dev-ruby / debug_inspector / debug_inspector-0.0.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 USE_RUBY="ruby23 ruby24 ruby25 ruby26"
6
7 RUBY_FAKEGEM_TASK_TEST=""
8
9 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
10 RUBY_FAKEGEM_EXTRADOC="README.md"
11
12 inherit ruby-fakegem
13
14 DESCRIPTION="A Ruby wrapper for the MRI 2.0 debug_inspector API"
15 HOMEPAGE="https://github.com/banister/debug_inspector"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="~amd64"
20 IUSE=""
21
22 each_ruby_configure() {
23         ${RUBY} -Cext/${PN} extconf.rb || die
24 }
25
26 each_ruby_compile() {
27         emake V=1 -Cext/${PN}
28         cp ext/${PN}/${PN}.so lib/ || die
29 }