dev-ruby/daemons: add 1.3.0
[gentoo.git] / dev-ruby / daemons / daemons-1.2.6.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 USE_RUBY="ruby23 ruby24 ruby25"
6
7 RUBY_FAKEGEM_EXTRADOC="Releases README.md"
8 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
9
10 RUBY_FAKEGEM_RECIPE_TEST="rspec3"
11
12 inherit ruby-fakegem
13
14 DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
15 HOMEPAGE="https://github.com/thuehlinger/daemons"
16 SRC_URI="https://github.com/thuehlinger/daemons/archive/v${PV}.tar.gz -> ${P}.tar.gz"
17
18 LICENSE="MIT"
19 SLOT="0"
20 KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
21 IUSE="examples"
22
23 all_ruby_prepare() {
24         sed -i -e '/\(pry\|simplecov\)/I s:^:#:' spec/spec_helper.rb || die
25 }
26
27 all_ruby_install() {
28         all_fakegem_install
29
30         use examples || return
31
32         insinto /usr/share/doc/${PF}/
33         doins -r examples
34 }