963e01e376a0f0dacd7365abd19f7b4e600ebd8b
[gentoo.git] / dev-ruby / daemons / daemons-1.2.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 USE_RUBY="ruby19 ruby20 ruby21 ruby22"
7
8 RUBY_FAKEGEM_EXTRADOC="Releases README.md"
9 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
10
11 RUBY_FAKEGEM_TASK_TEST=""
12
13 inherit ruby-fakegem
14
15 DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
16 HOMEPAGE="https://github.com/thuehlinger/daemons"
17
18 LICENSE="MIT"
19 SLOT="0"
20 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
21 IUSE="examples"
22
23 all_ruby_install() {
24         all_fakegem_install
25
26         use examples || return
27
28         insinto /usr/share/doc/${PF}/
29         doins -r examples
30 }