dev-ruby/ruby-net-ldap: add 0.14.0
[gentoo.git] / dev-ruby / coderay / coderay-1.1.0-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 USE_RUBY="ruby19 ruby20 jruby"
8
9 # The test target also contains test:exe but that requires
10 # shoulda-context which we do not have packaged yet.
11 RUBY_FAKEGEM_TASK_TEST="test:functional test:units"
12
13 RUBY_FAKEGEM_TASK_DOC="doc"
14 RUBY_FAKEGEM_DOCDIR="doc"
15
16 RUBY_FAKEGEM_EXTRADOC="Changes-pre-1.0.textile Changes.textile FOLDERS README_INDEX.rdoc README.markdown"
17
18 inherit ruby-fakegem
19
20 DESCRIPTION="A Ruby library for syntax highlighting"
21 HOMEPAGE="http://coderay.rubychan.de/"
22 SRC_URI="https://github.com/rubychan/coderay/tarball/v${PV} -> ${P}.tgz"
23
24 RUBY_S="rubychan-coderay-*"
25
26 LICENSE="MIT"
27 SLOT="0"
28 KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
29 IUSE=""
30
31 # Redcloth is optional but automagically tested, so we add this
32 # dependency to ensure that we get at least a version that works: bug
33 # 330621. We use this convoluted way because redcloth isn't available
34 # yet for jruby.
35 USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( >=dev-ruby/redcloth-4.2.2 )"
36
37 all_ruby_prepare() {
38         sed -i -e "/[Bb]undler/d" Rakefile || die
39         sed -i -e '/git ls-files/ s:^:#:' coderay.gemspec || die
40 }