x11-libs/libdrm: Switch to using Meson build system
[gentoo.git] / dev-ruby / bunny / bunny-2.6.5.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 USE_RUBY="ruby21 ruby22 ruby23"
6
7 RUBY_FAKEGEM_TASK_DOC=""
8
9 # Tests require a live AMQP server.
10 RUBY_FAKEGEM_TASK_TEST=""
11
12 RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
13
14 RUBY_FAKEGEM_BINWRAP=""
15
16 inherit ruby-fakegem
17
18 DESCRIPTION="Another synchronous Ruby AMQP client"
19 HOMEPAGE="https://github.com/celldee/bunny"
20
21 LICENSE="MIT"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"
24 IUSE=""
25
26 ruby_add_rdepend ">=dev-ruby/amq-protocol-2.0.1:2"
27
28 all_ruby_install() {
29         all_fakegem_install
30
31         insinto /usr/share/doc/${PF}
32         doins -r examples || die
33 }