dev-qt/linguist-tools: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ruby / bindata / bindata-2.4.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 USE_RUBY="ruby24 ruby25 ruby26 ruby27"
6
7 inherit ruby-fakegem
8
9 DESCRIPTION="Parsing Binary Data in Ruby"
10 HOMEPAGE="https://github.com/dmendel/bindata"
11
12 LICENSE="BSD-2"
13 SLOT="2"
14 KEYWORDS="~amd64 ~arm ~x86"
15 IUSE=""
16
17 ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
18
19 all_ruby_prepare() {
20         sed -i -e '/[Bb]undler/d' Rakefile || die
21         sed -i -e '/[Cc]overalls/d' test/test_helper.rb || die
22 }