dev-ruby/addressable: add 2.7.0
[gentoo.git] / dev-ruby / addressable / addressable-2.7.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 USE_RUBY="ruby24 ruby25 ruby26"
6
7 RUBY_FAKEGEM_RECIPE_TEST="rspec3"
8
9 RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
10
11 RUBY_FAKEGEM_EXTRAINSTALL="data"
12
13 inherit ruby-fakegem
14
15 DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
16 HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
17
18 LICENSE="Apache-2.0"
19
20 SLOT="0"
21 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
22 IUSE="doc test"
23
24 ruby_add_rdepend "|| ( dev-ruby/public_suffix:4 dev-ruby/public_suffix:3 )"
25
26 ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
27
28 all_ruby_prepare() {
29         # Remove spec-related tasks so that we don't need to require rspec
30         # just to build the documentation, bug 383611.
31         sed -i -e '/spectask/d' Rakefile || die
32         rm -f tasks/rspec.rake || die
33         sed -i -e '/bundler/ s:^:#:' \
34                 -e '/^begin/,/^end/ s:^:#:' \
35                 spec/spec_helper.rb || die
36
37         # Remove specs requiring network connectivity
38         rm -f spec/addressable/net_http_compat_spec.rb || die
39
40         # Remove spec that tests against an unreleased github fork
41         rm -f spec/addressable/rack_mount_compat_spec.rb || die
42 }