dev-ruby/activesupport: add ruby22
[gentoo.git] / dev-ruby / activesupport / activesupport-4.1.13.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 USE_RUBY="ruby19 ruby20 ruby21"
8
9 RUBY_FAKEGEM_TASK_DOC=""
10
11 RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
12
13 RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
14
15 RUBY_FAKEGEM_BINWRAP=""
16
17 inherit ruby-fakegem versionator
18
19 DESCRIPTION="Utility Classes and Extension to the Standard Library"
20 HOMEPAGE="https://github.com/rails/rails"
21 SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
22
23 LICENSE="MIT"
24 SLOT="$(get_version_component_range 1-2)"
25 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
26 IUSE=""
27
28 RUBY_S="rails-${PV}/${PN}"
29
30 ruby_add_rdepend "
31         >=dev-ruby/i18n-0.6.9:0.6
32         >=dev-ruby/json-1.7.7:0
33         >=dev-ruby/tzinfo-1.1:1
34         >=dev-ruby/minitest-5.1:5
35         >=dev-ruby/thread_safe-0.1:0"
36
37 # memcache-client, nokogiri, and builder are not strictly
38 # needed, but there are tests using this code.
39 ruby_add_bdepend "test? (
40         >=dev-ruby/dalli-2.2.1
41         >=dev-ruby/nokogiri-1.4.5
42         >=dev-ruby/builder-3.1.0
43         >=dev-ruby/libxml-2.0.0
44         )"
45
46 all_ruby_prepare() {
47         # Set the secure permissions that tests expect.
48         chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
49
50         # Set test environment to our hand.
51 #       rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
52         sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
53
54         # Avoid test that seems to be broken by lack of DST.
55         sed -i -e '369 s:^:#:' test/core_ext/string_ext_test.rb || die
56
57         # Avoid test that fails with Minitest 5.4 since that already defines
58         # a string E in its TestCase.
59         rm test/core_ext/marshal_test.rb || die
60         sed -i -e '/test_const_missing_in_anonymous_modules/askip "gentoo minitest"' test/dependencies_test.rb || die
61 }