Merge remote-tracking branch 'github/pr/517'.
[gentoo.git] / dev-ruby / activesupport / activesupport-4.0.13-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 USE_RUBY="ruby19 ruby20 ruby21"
8
9 RUBY_FAKEGEM_TASK_DOC=""
10
11 RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
12
13 RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
14
15 RUBY_FAKEGEM_BINWRAP=""
16
17 inherit ruby-fakegem versionator
18
19 DESCRIPTION="Utility Classes and Extension to the Standard Library"
20 HOMEPAGE="https://github.com/rails/rails"
21 SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
22
23 LICENSE="MIT"
24 SLOT="$(get_version_component_range 1-2)"
25 KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
26 IUSE=""
27
28 RUBY_S="rails-${PV}/${PN}"
29
30 ruby_add_rdepend "
31         >=dev-ruby/multi_json-1.3:0
32         >=dev-ruby/i18n-0.6.9:0.6
33         >=dev-ruby/tzinfo-0.3.37:0
34         >=dev-ruby/minitest-4.2:0
35         >=dev-ruby/thread_safe-0.1:0
36         !!<dev-ruby/activesupport-3.0.11-r1:3.0"
37
38 # memcache-client, nokogiri, and builder are not strictly
39 # needed, but there are tests using this code.
40 ruby_add_bdepend "test? (
41         >=dev-ruby/dalli-2.2.1
42         >=dev-ruby/nokogiri-1.4.5
43         >=dev-ruby/builder-3.1.0
44         >=dev-ruby/libxml-2.0.0
45         )"
46
47 RUBY_PATCHES=( "4-1-xml_depth.patch" )
48
49 all_ruby_prepare() {
50         # Set the secure permissions that tests expect.
51         chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
52
53         # Set test environment to our hand.
54 #       rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
55         sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
56
57         # Make sure a compatible version of minitest is used everywhere.
58         sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 4.2'/" lib/active_support/test_case.rb || die
59         sed -i -e "1igem 'minitest', '~> 4.2'" test/abstract_unit.rb || die
60
61         # Avoid test that seems to be broken by lack of DST.
62         sed -i -e '324 s:^:#:' test/core_ext/string_ext_test.rb || die
63 }