dev-ruby/activemodel: add rails 6.0.2.1
[gentoo.git] / dev-ruby / activemodel / activemodel-6.0.2.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 USE_RUBY="ruby25 ruby26"
7
8 RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
9
10 RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
11
12 RUBY_FAKEGEM_BINWRAP=""
13
14 inherit ruby-fakegem
15
16 DESCRIPTION="Toolkit for building modeling frameworks like Active Record and Active Resource"
17 HOMEPAGE="https://github.com/rails/rails"
18 SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
19
20 LICENSE="MIT"
21 SLOT="$(ver_cut 1-2)"
22 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
23 IUSE=""
24
25 RUBY_S="rails-${PV}/${PN}"
26
27 ruby_add_rdepend "
28         ~dev-ruby/activesupport-${PV}:*
29 "
30
31 ruby_add_bdepend "
32         test? (
33                 ~dev-ruby/railties-${PV}
34                 dev-ruby/test-unit:2
35                 dev-ruby/mocha
36                 >=dev-ruby/bcrypt-ruby-3.1.7
37         )"
38
39 all_ruby_prepare() {
40         # Set test environment to our hand.
41         sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
42 }