dev-ruby/rubygems: add GPL-2 to the LICENSE to cover init script
[gentoo.git] / dev-ruby / activemodel / activemodel-5.1.4.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 USE_RUBY="ruby22 ruby23 ruby24"
7
8 RUBY_FAKEGEM_TASK_DOC=""
9 RUBY_FAKEGEM_DOCDIR=""
10 RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
11
12 RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
13
14 RUBY_FAKEGEM_BINWRAP=""
15
16 inherit ruby-fakegem versionator
17
18 DESCRIPTION="Toolkit for building modeling frameworks like Active Record and Active Resource"
19 HOMEPAGE="https://github.com/rails/rails"
20 SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
21
22 LICENSE="MIT"
23 SLOT="$(get_version_component_range 1-2)"
24 KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
25 IUSE=""
26
27 RUBY_S="rails-${PV}/${PN}"
28
29 ruby_add_rdepend "
30         ~dev-ruby/activesupport-${PV}:*
31 "
32
33 ruby_add_bdepend "
34         test? (
35                 ~dev-ruby/railties-${PV}
36                 dev-ruby/test-unit:2
37                 >=dev-ruby/mocha-0.14.0:0.14
38                 >=dev-ruby/bcrypt-ruby-3.1.7
39         )"
40
41 all_ruby_prepare() {
42         # Set test environment to our hand.
43         sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
44 }