www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / dev-ruby / activejob / activejob-6.0.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 USE_RUBY="ruby25 ruby26"
7
8 RUBY_FAKEGEM_RECIPE_DOC=""
9 RUBY_FAKEGEM_DOCDIR=""
10 RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
11
12 RUBY_FAKEGEM_BINWRAP=""
13
14 RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
15
16 inherit ruby-fakegem
17
18 DESCRIPTION="Job framework with pluggable queues"
19 HOMEPAGE="https://github.com/rails/rails"
20 SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
21
22 LICENSE="MIT"
23 SLOT="$(ver_cut 1-2)"
24 KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
25 IUSE=""
26
27 RUBY_S="rails-${PV}/${PN}"
28
29 ruby_add_rdepend "
30         ~dev-ruby/activesupport-${PV}
31         >=dev-ruby/globalid-0.3.6
32 "
33
34 ruby_add_bdepend "
35         test? (
36                 dev-ruby/mocha
37         )"
38
39 all_ruby_prepare() {
40         # Set test environment to our hand.
41         sed -i -e '/load_paths/d' test/helper.rb || die "Unable to remove load paths"
42
43         # Remove all currently unpackaged queues.
44         sed -i -e 's/que queue_classic resque sidekiq sneakers sucker_punch backburner//' \
45                 -e 's/delayed_job//' Rakefile || die
46         sed -i -e '/SneakersAdapter/ s:^:#:' test/cases/exceptions_test.rb || die
47 }