dev-ruby/activejob: add rails 5.1.2
[gentoo.git] / dev-ruby / activejob / activejob-5.0.4.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 USE_RUBY="ruby22 ruby23 ruby24"
7
8 RUBY_FAKEGEM_TASK_DOC=""
9 RUBY_FAKEGEM_DOCDIR=""
10 RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
11
12 RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
13
14 inherit ruby-fakegem versionator
15
16 DESCRIPTION="Job framework with pluggable queues"
17 HOMEPAGE="https://github.com/rails/rails"
18 SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
19
20 LICENSE="MIT"
21 SLOT="$(get_version_component_range 1-2)"
22 KEYWORDS="~amd64 ~arm ~amd64-linux"
23 IUSE=""
24
25 RUBY_S="rails-${PV}/${PN}"
26
27 ruby_add_rdepend "
28         ~dev-ruby/activesupport-${PV}
29         >=dev-ruby/globalid-0.3.6
30 "
31
32 ruby_add_bdepend "
33         test? (
34                 >=dev-ruby/mocha-0.14.0:0.14
35         )"
36
37 all_ruby_prepare() {
38         # Set test environment to our hand.
39         sed -i -e '1igem "activesupport", "~>5.0.0"' test/helper.rb || die
40
41         # Remove all currently unpackaged queues.
42         sed -i -e 's/delayed_job que queue_classic resque sidekiq sneakers sucker_punch backburner//' Rakefile || die
43 }