dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ruby / actionpack-xml_parser / actionpack-xml_parser-2.0.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 USE_RUBY="ruby24 ruby25 ruby26"
6
7 RUBY_FAKEGEM_TASK_DOC=""
8
9 inherit ruby-fakegem
10
11 DESCRIPTION="XML parameters parser for Action Pack (removed from core in Rails 4.0)"
12 HOMEPAGE="https://github.com/rails/actionpack-xml_parser"
13 SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="MIT"
16
17 KEYWORDS="~amd64"
18 SLOT="2"
19 IUSE=""
20
21 ruby_add_rdepend "=dev-ruby/actionpack-5*:* =dev-ruby/railties-5*:*"
22
23 all_ruby_prepare() {
24         sed -i -e "/bundler/d" Rakefile test/helper.rb || die
25         sed -i -e '1igem "actionpack", "~>5.2"' test/helper.rb || die
26
27         # Skip test that is not compatible with Rails 5.2
28         sed -i -e '/occurring a parse error if parsing unsuccessful/askip "rails 5.2"' test/xml_params_parsing_test.rb || die
29 }
30
31 each_ruby_test() {
32         MT_NO_PLUGINS=true ${RUBY} -Ilib:.:test -e "Dir['test/*_test.rb'].each{|f| require f}" || die
33 }