Merge remote-tracking branch 'remotes/github/pr/52'.
[gentoo.git] / dev-ros / visp_hand2eye_calibration / visp_hand2eye_calibration-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/lagadic/vision_visp"
7 KEYWORDS="~amd64 ~arm"
8 VER_PREFIX="jade-"
9 ROS_SUBDIR=${PN}
10 CATKIN_HAS_MESSAGES=yes
11 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
12 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
13
14 inherit ros-catkin
15
16 DESCRIPTION="Estimates the camera position with respect to its effector using the ViSP library"
17 LICENSE="GPL-2"
18 SLOT="0"
19 IUSE=""
20
21 RDEPEND="
22         dev-ros/image_proc
23         dev-ros/roscpp
24         dev-ros/sensor_msgs
25         dev-ros/visp_bridge
26         dev-ros/visp_tracker
27         sci-libs/ViSP:=
28 "
29 DEPEND="${RDEPEND}"
30 if [ "${PV#9999}" = "${PV}" ] ; then
31         S="${WORKDIR}/vision_visp-jade-${PV}/${ROS_SUBDIR}"
32 fi