*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / visp_hand2eye_calibration / visp_hand2eye_calibration-0.11.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/lagadic/vision_visp"
6 KEYWORDS="~amd64 ~arm"
7 VER_PREFIX="kinetic-"
8 ROS_SUBDIR=${PN}
9 CATKIN_HAS_MESSAGES=yes
10 PYTHON_COMPAT=( python2_7 )
11 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
12
13 inherit ros-catkin
14
15 DESCRIPTION="Estimates the camera position with respect to its effector using the ViSP library"
16 LICENSE="GPL-2"
17 SLOT="0"
18 IUSE=""
19
20 RDEPEND="
21         dev-ros/image_proc
22         dev-ros/roscpp
23         dev-ros/sensor_msgs
24         dev-ros/visp_bridge
25         dev-ros/visp_tracker
26         sci-libs/ViSP:=
27 "
28 DEPEND="${RDEPEND}"
29 if [ "${PV#9999}" = "${PV}" ] ; then
30         S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}"
31 fi