dev-python/aiodns: arm64 keyworded (bug #723444)
[gentoo.git] / dev-ros / visp_hand2eye_calibration / visp_hand2eye_calibration-0.11.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 ROS_REPO_URI="https://github.com/lagadic/vision_visp"
6 KEYWORDS="~amd64 ~arm"
7 VER_PREFIX="kinetic-"
8 ROS_SUBDIR=${PN}
9 CATKIN_HAS_MESSAGES=yes
10 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
11
12 inherit ros-catkin
13
14 DESCRIPTION="Estimates the camera position with respect to its effector using ViSP"
15 LICENSE="GPL-2"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-ros/image_proc
21         dev-ros/roscpp
22         dev-ros/sensor_msgs
23         dev-ros/visp_bridge
24         dev-ros/visp_tracker
25         sci-libs/ViSP:=
26 "
27 DEPEND="${RDEPEND}"
28 if [ "${PV#9999}" = "${PV}" ] ; then
29         S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}"
30 fi