dev-ros/urg_node: update live ebuild and bump to 0.1.11
[gentoo.git] / dev-ros / urg_node / urg_node-0.1.11.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-drivers/urg_node"
6 KEYWORDS="~amd64 ~arm"
7 PYTHON_COMPAT=( python2_7 )
8 CATKIN_HAS_MESSAGES=yes
9
10 inherit ros-catkin
11
12 DESCRIPTION="ROS wrapper for the Hokuyo urg_c library"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/urg_c
19         dev-ros/tf
20         dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
21         dev-ros/nodelet
22         dev-ros/rosconsole
23         dev-ros/roscpp
24         dev-ros/diagnostic_updater
25         dev-ros/laser_proc
26         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
27         dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
28         dev-libs/boost:=
29 "
30 DEPEND="${RDEPEND}"