dev-python/Babel: Drop old
[gentoo.git] / dev-ros / unique_id / unique_id-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros-geographic-info/unique_identifier"
7 VER_PREFIX=unique_identifier-
8 KEYWORDS="~amd64 ~arm"
9 PYTHON_COMPAT=( python2_7 )
10 ROS_SUBDIR=${PN}
11
12 inherit ros-catkin
13
14 DESCRIPTION="ROS Python and C++ interfaces for universally unique identifiers"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
21         dev-ros/rospy[${PYTHON_USEDEP}]
22         dev-ros/roscpp
23 "
24 DEPEND="${RDEPEND}
25         test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"