dev-python/cbor: New pkg, new dep of dev-python/autobahn-0.16.0
[gentoo.git] / dev-ros / turtlesim / turtlesim-0.7.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros/ros_tutorials"
7 KEYWORDS="~amd64 ~arm"
8 ROS_SUBDIR=${PN}
9 CATKIN_HAS_MESSAGES=yes
10 PYTHON_COMPAT=( python2_7 )
11 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/std_srvs dev-ros/geometry_msgs"
12
13 inherit ros-catkin
14
15 DESCRIPTION="Tool made for teaching ROS and ROS packages"
16 LICENSE="BSD"
17 SLOT="0"
18 IUSE=""
19
20 RDEPEND="
21         dev-qt/qtcore:5
22         dev-qt/qtgui:5
23         dev-qt/qtwidgets:5
24         dev-libs/boost:=[threads]
25         dev-ros/rosconsole
26         dev-ros/roscpp
27         dev-ros/roscpp_serialization
28         dev-ros/roslib
29         dev-ros/rostime
30         dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
31         dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
32 "
33 DEPEND="${RDEPEND}"