dev-python/Babel: Drop old
[gentoo.git] / dev-ros / tf_conversions / tf_conversions-1.11.7.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 CATKIN_HAS_MESSAGES=yes
7 ROS_REPO_URI="https://github.com/ros/geometry"
8 KEYWORDS="~amd64 ~arm"
9 PYTHON_COMPAT=( python2_7 )
10 ROS_SUBDIR=${PN}
11
12 inherit ros-catkin
13
14 DESCRIPTION="Conversion functions to convert common tf datatypes into identical datatypes used by other libraries"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
21         dev-ros/kdl_conversions
22         dev-ros/tf[${PYTHON_USEDEP}]
23         sci-libs/orocos_kdl
24         dev-cpp/eigen:3
25         dev-ros/rospy[${PYTHON_USEDEP}]
26 "
27 DEPEND="${RDEPEND}
28         test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"