dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ros / tf2_sensor_msgs / tf2_sensor_msgs-0.6.5.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros/geometry2"
6 KEYWORDS="~amd64 ~arm"
7 ROS_SUBDIR=${PN}
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="Transform sensor_msgs with tf. Most notably, PointCloud2"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/tf2_ros[${PYTHON_USEDEP}]
19         dev-ros/tf2
20         dev-ros/rospy[${PYTHON_USEDEP}]
21         dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
22         dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
23 "
24 DEPEND="${RDEPEND}
25         test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
26         dev-ros/cmake_modules"