kde-plasma: Add KDE Plasma 5.11.4
[gentoo.git] / dev-ros / tf2_ros / tf2_ros-0.5.16.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros/geometry2"
6 KEYWORDS="~amd64 ~arm"
7 ROS_SUBDIR=${PN}
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="ROS bindings for the tf2 library, for both Python and C++"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/actionlib[${PYTHON_USEDEP}]
19         dev-ros/message_filters
20         dev-ros/roscpp
21         dev-ros/rosgraph
22         dev-libs/boost:=[threads]
23         dev-ros/rospy[${PYTHON_USEDEP}]
24         dev-ros/tf2
25         dev-ros/tf2_py[${PYTHON_USEDEP}]
26         dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
27         dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
28         dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
29 "
30 DEPEND="${RDEPEND}
31         test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"