dev-ros/rviz_plugin_tutorials: Bump to 0.11.0.
[gentoo.git] / dev-ros / tf2_kdl / tf2_kdl-9999.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros/geometry2"
6 KEYWORDS="~amd64 ~arm"
7 ROS_SUBDIR=${PN}
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="KDL binding for tf2"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-cpp/eigen:3
19         dev-ros/tf2
20         dev-ros/tf2_ros
21         dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
22         sci-libs/orocos_kdl:=
23         dev-ros/tf2_msgs[${PYTHON_USEDEP}]
24         dev-ros/cmake_modules
25 "
26 DEPEND="${RDEPEND}
27         test? (
28                 dev-ros/rostest[${PYTHON_USEDEP}]
29                 dev-cpp/gtest
30         )"