dev-ros/compressed_depth_image_transport: Initial import. Ebuild by me.
[gentoo.git] / dev-ros / tf2 / tf2-0.5.12.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 ROS_REPO_URI="https://github.com/ros/geometry_experimental"
7 KEYWORDS="~amd64 ~arm"
8 ROS_SUBDIR=${PN}
9
10 inherit ros-catkin
11
12 DESCRIPTION="The second generation Transform Library in ROS"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/tf2_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
19         dev-libs/console_bridge
20         dev-ros/rostime
21         dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
22         dev-libs/boost:=[threads]
23 "
24 DEPEND="${RDEPEND}"