dev-ros/move_base: Bump to 1.16.6.
[gentoo.git] / dev-ros / test_rosservice / test_rosservice-1.14.3-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros/ros_comm"
7 KEYWORDS="~amd64 ~arm"
8 ROS_SUBDIR=test/${PN}
9 CATKIN_HAS_MESSAGES=yes
10 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
11
12 PYTHON_COMPAT=( python2_7 )
13
14 inherit ros-catkin
15
16 DESCRIPTION="Unit tests for rospy"
17 LICENSE="BSD"
18 SLOT="0"
19 IUSE=""
20
21 RDEPEND=""
22 DEPEND="${RDEPEND}
23         dev-ros/rostest[${PYTHON_USEDEP}]
24         dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
25         test? (
26                 dev-ros/test_rosmaster[${PYTHON_USEDEP}]
27                 dev-ros/rospy[${PYTHON_USEDEP}]
28                 dev-ros/rostest[${PYTHON_USEDEP}]
29                 dev-python/nose[${PYTHON_USEDEP}]
30         )"
31 PATCHES=( "${FILESDIR}/yaml.patch" )