dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ros / test_rospy / test_rospy-1.15.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros/ros_comm"
7 KEYWORDS="~amd64 ~arm"
8 ROS_SUBDIR=test/${PN}
9 CATKIN_HAS_MESSAGES=yes
10 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
11
12 PYTHON_COMPAT=( python2_7 )
13
14 inherit ros-catkin
15
16 DESCRIPTION="Unit tests for rospy"
17 LICENSE="BSD"
18 SLOT="0"
19 IUSE=""
20
21 RDEPEND=""
22 DEPEND="${RDEPEND}
23         dev-ros/rostest[${PYTHON_USEDEP}]
24         dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
25         dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
26         dev-ros/rosunit[${PYTHON_USEDEP}]
27         test? (
28                 dev-python/numpy[${PYTHON_USEDEP}]
29                 dev-ros/rosbuild
30                 dev-ros/rosgraph[${PYTHON_USEDEP}]
31                 dev-ros/rospy[${PYTHON_USEDEP}]
32                 dev-python/nose[${PYTHON_USEDEP}]
33         )"