Merge remote-tracking branch 'github/pr/218'.
[gentoo.git] / dev-ros / test_rospy / test_rospy-1.11.16.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 ROS_REPO_URI="https://github.com/ros/ros_comm"
8 KEYWORDS="~amd64 ~arm"
9 ROS_SUBDIR=test/${PN}
10 CATKIN_HAS_MESSAGES=yes
11 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
12
13 PYTHON_COMPAT=( python2_7 )
14
15 inherit ros-catkin
16
17 DESCRIPTION="Unit tests for rospy"
18 LICENSE="BSD"
19 SLOT="0"
20 IUSE=""
21
22 RDEPEND=""
23 DEPEND="${RDEPEND}
24         dev-ros/rostest[${PYTHON_USEDEP}]
25         dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
26         dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
27         dev-ros/rosunit[${PYTHON_USEDEP}]
28         test? (
29                 dev-python/numpy[${PYTHON_USEDEP}]
30                 dev-ros/rosbuild
31                 dev-ros/rosgraph[${PYTHON_USEDEP}]
32                 dev-ros/rospy[${PYTHON_USEDEP}]
33                 dev-python/nose[${PYTHON_USEDEP}]
34         )"