Merge remote-tracking branch 'remotes/github/pr/975'
[gentoo.git] / dev-ros / test_rosmaster / test_rosmaster-1.12.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 ROS_REPO_URI="https://github.com/ros/ros_comm"
8 KEYWORDS="~amd64 ~arm"
9 ROS_SUBDIR=test/${PN}
10 CATKIN_HAS_MESSAGES=yes
11
12 PYTHON_COMPAT=( python2_7 )
13
14 inherit ros-catkin
15
16 DESCRIPTION="Unit tests for rosmaster"
17 LICENSE="BSD"
18 SLOT="0"
19 IUSE=""
20
21 RDEPEND="dev-ros/rosgraph[${PYTHON_USEDEP}]
22         dev-ros/rostest[${PYTHON_USEDEP}]
23         dev-ros/std_msgs[${PYTHON_USEDEP}]"
24 DEPEND="${RDEPEND}
25         test? ( dev-ros/roslib[${PYTHON_USEDEP}] )
26 "
27
28 mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )
29
30 src_install() {
31         ros-catkin_src_install
32         dodir /usr/share/${PN}
33         cp -a test "${ED}//usr/share/${PN}/" || die
34 }