dev-ruby/shotgun: add ruby26
[gentoo.git] / dev-ros / test_roslib_comm / test_roslib_comm-1.14.2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros/ros_comm"
7 KEYWORDS="~amd64 ~arm"
8 ROS_SUBDIR=test/${PN}
9 CATKIN_HAS_MESSAGES=yes
10 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
11
12 PYTHON_COMPAT=( python2_7 )
13
14 inherit ros-catkin
15
16 DESCRIPTION="Unit tests for roslib"
17 LICENSE="BSD"
18 SLOT="0"
19 IUSE=""
20
21 RDEPEND=""
22 DEPEND="${RDEPEND}
23         test? ( dev-ros/roslib[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] dev-ros/test_rosmaster )
24 "