dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-ros / test_roscpp / test_roscpp-1.15.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros/ros_comm"
7 KEYWORDS="~amd64 ~arm"
8 ROS_SUBDIR=test/${PN}
9 CATKIN_HAS_MESSAGES=yes
10 PYTHON_COMPAT=( python2_7 )
11 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
12
13 inherit ros-catkin
14
15 DESCRIPTION="Unit tests for roscpp"
16 LICENSE="BSD"
17 SLOT="0"
18 IUSE=""
19
20 RDEPEND=""
21 DEPEND="${RDEPEND}
22         dev-ros/roscpp
23         dev-ros/rostest[${PYTHON_USEDEP}]
24         dev-ros/rosunit[${PYTHON_USEDEP}]
25         dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
26         dev-libs/boost:=[threads]
27         test? (
28                 dev-cpp/gtest
29         )
30 "
31 REQUIRED_USE="test? ( ros_messages_cxx )"