dev-ros/genpy: bump to 0.6.11
[gentoo.git] / dev-ros / stereo_image_proc / stereo_image_proc-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
6 KEYWORDS="~amd64 ~arm"
7 PYTHON_COMPAT=( python2_7 )
8 ROS_SUBDIR=${PN}
9
10 inherit ros-catkin
11
12 DESCRIPTION="Stereo and single image rectification and disparity processing"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/cv_bridge
19         dev-ros/dynamic_reconfigure
20         dev-ros/image_geometry
21         dev-ros/image_proc
22         dev-ros/image_transport
23         dev-ros/message_filters
24         dev-ros/nodelet
25         dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
26         dev-ros/stereo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
27         media-libs/opencv:=
28         dev-libs/boost:=[threads]
29         dev-libs/console_bridge:=
30 "
31 DEPEND="${RDEPEND}"