aefa49d98a85692ade83e13790af4771724ecaca
[gentoo.git] / dev-ros / shape_msgs / shape_msgs-9999.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 CATKIN_HAS_MESSAGES=yes
6 ROS_REPO_URI="https://github.com/ros/common_msgs"
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
9 ROS_SUBDIR=${PN}
10 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
11
12 inherit ros-catkin
13
14 DESCRIPTION="Messages for defining shapes, such as simple solid object primitives, planes, and meshes"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND=""
20 DEPEND="${RDEPEND}"