dev-ros/urg_c: eapi7
[gentoo.git] / dev-ros / rqt_topic / rqt_topic-0.4.10.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 KEYWORDS="~amd64"
7 ROS_REPO_URI="https://github.com/ros-visualization/rqt_topic"
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="GUI plugin for displaying debug information about ROS topics"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-python/rospkg[${PYTHON_USEDEP}]
19         dev-ros/rostopic[${PYTHON_USEDEP}]
20         dev-ros/rqt_gui[${PYTHON_USEDEP}]
21         dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
22         dev-ros/std_msgs[${PYTHON_USEDEP}]
23         >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
24 "
25 DEPEND="${RDEPEND}"