dev-ros/genpy: bump to 0.6.11
[gentoo.git] / dev-ros / rqt_rviz / rqt_rviz-0.6.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 KEYWORDS="~amd64"
7 ROS_REPO_URI="https://github.com/ros-visualization/rqt_rviz"
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="GUI plugin embedding RViz"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-libs/boost:=
19         dev-ros/pluginlib[${PYTHON_USEDEP}]
20         dev-ros/rqt_gui[${PYTHON_USEDEP}]
21         dev-ros/rqt_gui_cpp
22         >=dev-ros/qt_gui_cpp-0.3
23         dev-qt/qtwidgets:5
24         dev-ros/rviz
25         dev-libs/console_bridge:=
26 "
27 DEPEND="${RDEPEND}"