dev-ros/visp_bridge: eapi7
[gentoo.git] / dev-ros / rqt_runtime_monitor / rqt_runtime_monitor-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 KEYWORDS="~amd64"
7 ROS_REPO_URI="https://github.com/ros-visualization/rqt_runtime_monitor"
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="GUI plugin viewing DiagnosticsArray messages"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
19         dev-python/rospkg[${PYTHON_USEDEP}]
20         dev-ros/qt_gui[${PYTHON_USEDEP}]
21         dev-ros/rospy[${PYTHON_USEDEP}]
22         dev-ros/rqt_gui[${PYTHON_USEDEP}]
23         dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
24 "
25 DEPEND="${RDEPEND}"