Merge remote-tracking branch 'remotes/github/pr/116'.
[gentoo.git] / dev-ros / rqt_gui_py / rqt_gui_py-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 ROS_REPO_URI="https://github.com/ros-visualization/rqt"
8 KEYWORDS="~amd64"
9 PYTHON_COMPAT=( python2_7 )
10 ROS_SUBDIR=${PN}
11
12 inherit ros-catkin
13
14 DESCRIPTION="Enables GUI plugins to use the Python client library for ROS"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-ros/rospy[${PYTHON_USEDEP}]
21         dev-ros/qt_gui[${PYTHON_USEDEP}]
22         dev-ros/rqt_gui[${PYTHON_USEDEP}]
23 "
24 DEPEND="${RDEPEND}"