dev-python/cherrypy: keyworded 18.5.0 for ia64, bug #717946
[gentoo.git] / dev-ros / rqt_gui_cpp / rqt_gui_cpp-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros-visualization/rqt"
7 KEYWORDS="~amd64"
8 ROS_SUBDIR=${PN}
9
10 inherit ros-catkin
11
12 DESCRIPTION="Enables GUI plugins to use the C++ client library for ROS"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-qt/qtwidgets:5
19         dev-qt/qtcore:5
20         >=dev-ros/qt_gui_cpp-0.3.0
21         >=dev-ros/qt_gui-0.3.0
22         dev-ros/roscpp
23         dev-ros/nodelet
24                 dev-libs/tinyxml2:=
25         dev-libs/boost:=
26         dev-libs/console_bridge:=
27 "
28 DEPEND="${RDEPEND}"