*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / rqt_gui / rqt_gui-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros-visualization/rqt"
7 KEYWORDS="~amd64"
8 PYTHON_COMPAT=( python2_7 )
9 ROS_SUBDIR=${PN}
10
11 inherit ros-catkin
12
13 DESCRIPTION="Main to start an instance of the ROS integrated graphical user interface provided by qt_gui"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
20         dev-libs/boost:="
21 DEPEND="${RDEPEND}"
22 PATCHES=( "${FILESDIR}/gentoo.patch" )