dev-java/hibernate: Stable for amd64. Stable for x86 using the ALLARCHES policy.
[gentoo.git] / dev-ros / rqt_graph / rqt_graph-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 KEYWORDS="~amd64"
8 ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
9 PYTHON_COMPAT=( python2_7 )
10 ROS_SUBDIR=${PN}
11
12 inherit ros-catkin
13
14 DESCRIPTION="GUI plugin for visualizing the ROS computation graph"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-python/rospkg[${PYTHON_USEDEP}]
21         dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
22         dev-ros/rosgraph[${PYTHON_USEDEP}]
23         dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
24         dev-ros/roslib[${PYTHON_USEDEP}]
25         dev-ros/rosnode[${PYTHON_USEDEP}]
26         dev-ros/rospy[${PYTHON_USEDEP}]
27         dev-ros/rosservice[${PYTHON_USEDEP}]
28         dev-ros/rostopic[${PYTHON_USEDEP}]
29         dev-ros/rqt_gui[${PYTHON_USEDEP}]
30         dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
31 "
32 DEPEND="${RDEPEND}"