dev-ros/rqt_nav_view: Bump to 0.5.3.
[gentoo.git] / dev-ros / rqt_console / rqt_console-0.4.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 KEYWORDS="~amd64"
8 ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
9 PYTHON_COMPAT=( python2_7 )
10 ROS_SUBDIR=${PN}
11
12 inherit ros-catkin
13
14 DESCRIPTION="GUI plugin for displaying and filtering ROS messages"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-python/rospkg[${PYTHON_USEDEP}]
21         dev-ros/roslib[${PYTHON_USEDEP}]
22         dev-ros/rospy[${PYTHON_USEDEP}]
23         dev-ros/rqt_gui[${PYTHON_USEDEP}]
24         dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
25         dev-ros/rqt_logger_level[${PYTHON_USEDEP}]
26         >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
27 "
28 DEPEND="${RDEPEND}"