dev-python/Babel: Drop old
[gentoo.git] / dev-ros / roswtf / roswtf-1.11.14.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 ROS_REPO_URI="https://github.com/ros/ros_comm"
8 KEYWORDS="~amd64 ~arm"
9 ROS_SUBDIR=utilities/${PN}
10 PYTHON_COMPAT=( python2_7 )
11
12 inherit ros-catkin
13
14 DESCRIPTION="Tool for diagnosing issues with a running ROS system"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-python/paramiko[${PYTHON_USEDEP}]
21         dev-ros/roslib[${PYTHON_USEDEP}]
22         dev-python/rospkg[${PYTHON_USEDEP}]"
23 DEPEND="${RDEPEND}
24         test? (
25                 dev-ros/rostest[${PYTHON_USEDEP}]
26                 dev-util/rosdep[${PYTHON_USEDEP}]
27                 dev-util/rosinstall[${PYTHON_USEDEP}]
28                 dev-python/nose[${PYTHON_USEDEP}]
29         )"
30
31 src_test() {
32         rosdep update
33         ros-catkin_src_test
34 }