dev-ros/cmake_modules: bump to 0.5.0
[gentoo.git] / dev-ros / rosserial_embeddedlinux / rosserial_embeddedlinux-0.7.1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
6 KEYWORDS="~amd64 ~arm"
7 PYTHON_COMPAT=( python2_7 )
8 ROS_SUBDIR=${PN}
9
10 inherit ros-catkin
11
12 DESCRIPTION="Libraries and examples for ROSserial usage on Embedded Linux Enviroments"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
19         dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
20         dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
21         dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
22         dev-ros/rosserial_client[${PYTHON_USEDEP}]
23         dev-ros/rospy[${PYTHON_USEDEP}]
24 "
25 DEPEND="${RDEPEND}"