Merge remote-tracking branch 'github/pr/1633', bug 527306 by Ettore Di Giacinto
[gentoo.git] / dev-ros / rosparam / rosparam-1.11.15.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 ROS_REPO_URI="https://github.com/ros/ros_comm"
8 KEYWORDS="~amd64 ~arm"
9 ROS_SUBDIR=tools/${PN}
10 PYTHON_COMPAT=( python2_7 )
11
12 inherit ros-catkin
13
14 DESCRIPTION="Command-line tool for getting and setting ROS Parameters on the parameter server"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-ros/rosgraph[${PYTHON_USEDEP}]
21         dev-python/pyyaml[${PYTHON_USEDEP}]
22 "
23 DEPEND="${RDEPEND}"