dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ros / rospack / rospack-2.5.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros/rospack"
7 KEYWORDS="~amd64 ~arm"
8
9 inherit ros-catkin
10
11 DESCRIPTION="Retrieves information about ROS packages available on the filesystem"
12
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
17
18 RDEPEND="
19         dev-libs/boost:=
20         >=dev-libs/tinyxml2-5:=
21         ${PYTHON_DEPS}"
22 DEPEND="${RDEPEND}
23         >=dev-ros/cmake_modules-0.4.1
24         test? (
25                 dev-cpp/gtest
26                 dev-python/nose
27         )"
28
29 PATCHES=(
30         "${FILESDIR}/gentoo.patch"
31 )