www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / dev-ros / rosmsg / rosmsg-1.14.3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros/ros_comm"
7 KEYWORDS="~amd64 ~arm"
8 ROS_SUBDIR=tools/${PN}
9 PYTHON_COMPAT=( python2_7 )
10
11 inherit ros-catkin
12
13 DESCRIPTION="Command-line tools for displaying information about message and services"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         dev-ros/genmsg[${PYTHON_USEDEP}]
20         dev-python/rospkg[${PYTHON_USEDEP}]
21         dev-ros/roslib[${PYTHON_USEDEP}]
22         dev-ros/rosbag[${PYTHON_USEDEP}]
23 "
24 DEPEND="${RDEPEND}
25         test? ( dev-ros/test_rosmaster[${PYTHON_USEDEP}] )
26 "
27 PATCHES=( "${FILESDIR}/py3.patch" "${FILESDIR}/norm.patch" "${FILESDIR}/tests.patch" )