net-libs/miniupnpc: Merge "Version bump to 1.9.20151008"
[gentoo.git] / dev-ros / rosgraph / rosgraph-1.11.14.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 ROS_REPO_URI="https://github.com/ros/ros_comm"
8 KEYWORDS="~amd64 ~arm"
9 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
10 ROS_SUBDIR=tools/${PN}
11
12 inherit ros-catkin
13
14 DESCRIPTION="Prints information about the ROS Computation Graph"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-python/netifaces[${PYTHON_USEDEP}]
21         dev-python/rospkg[${PYTHON_USEDEP}]"
22 DEPEND="${RDEPEND}
23         test? ( dev-python/mock[${PYTHON_USEDEP}] )"